Icecast Streaming Media Server Forum Index Icecast Streaming Media Server
Icecast is a Xiph Foundation Project
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Icecast crash

 
Post new topic   Reply to topic    Icecast Streaming Media Server Forum Index -> Icecast Server
View previous topic :: View next topic  
Author Message
luca066



Joined: 01 Dec 2011
Posts: 41

PostPosted: Wed May 20, 2015 12:02 am    Post subject: Icecast crash Reply with quote

Hi,

I'm experiencing an issue with Icecast 2.3.3 HK7.
It's running on a Centos 6 system at 64 bits and the issue is that once a day the icecast process hangs.

I was using HK5 version with the same issue, so I've done the upgrade to HK7 (at the moment I can't upgrade to something higher because after HK7 the xls file generated by Icecast is a little bit different and I need to change all the jobs that collect statistical data).

Anyway, I don't know why the process hangs.
I've a script on cron that check if Icecast is running and it starts Icecast if is not present in the process list.
The script write on a log file the date time if it starts Icecast, so I'm able to see how often the process hangs.

It happens once a day, but not with a regular interval: sometime it runs for 10 hours, sometime 2 hours, sometime 24 hours.
It happens with a low number of listeners connected, so I don't think it is a problem related the load of the server.

I've the log file at level 3, everytime it hangs I got these lines:


Code:

[2015-05-20  01:01:37] INFO admin/admin_handle_general_request processing file stats.xsl
[2015-05-20  01:01:37] INFO admin/admin_handle_general_request processing file stats.xsl
[2015-05-20  01:01:37] INFO xslt/xslt_update loaded stylesheet /opt/icecast/latest/share/icecast/admin/stats.xsl
[2015-05-20  01:01:37] INFO xslt/xslt_update loaded stylesheet /opt/icecast/latest/share/icecast/admin/stats.xsl
[2015-05-20  01:02:02] INFO thread/ lock abort set to 0
[2015-05-20  01:02:02] INFO main/server_process Icecast 2.3.3-kh7 server started
[2015-05-20  01:02:02] WARN slave/slave_startup process has 10000 max file descriptor limit
[2015-05-20  01:02:02] INFO client/workers_adjust requested worker count 1
[2015-05-20  01:02:02] INFO connection/connection_thread connection thread started
[2015-05-20  01:02:02] INFO connection/get_ssl_certificate No SSL capability


Now I've set the log file to level 4, debug mode.
Have you got any idea?
What can I do to find what is going wrong with this server?

Thanks for your answer

Luca
Back to top
View user's profile Send private message
karlH
Code Warrior
Code Warrior


Joined: 13 Jun 2005
Posts: 5476
Location: UK

PostPosted: Fri May 22, 2015 7:45 pm    Post subject: Reply with quote

Hard to pinpoint on that back to an older version, if you are really stuck on the issues of the xsl then use the older xsl files, if the issue is the xml output then let me know the change as that should be an easy change to get a new build working.

karl.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
luca066



Joined: 01 Dec 2011
Posts: 41

PostPosted: Sat May 23, 2015 10:17 pm    Post subject: Reply with quote

Thank you Karl for your answer.
I think I've found the solution, now it's about 3 days that I haven't any crash.
The server is a virtual server, it was running with 1 virtual core and 4GB of ram.
Now I've set 2 cores and 8GB of ram and it's working.
In the next days I'll try to understand if it was a cpu or a ram problem.

Anyway, I'd like to use the last version of Icecast as soon as possible.
My problem is the listclients?mount=/xxxx.
After HK7 that command returns a different xml from the previous version:
Code:

<listener id="245">
      <ID>245</ID>
      <IP>1.1.1.1</IP>
      <UserAgent>Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/600.5.17 (KHTML, like Gecko) Version/8.0.5 Safari/600.5.17</UserAgent>
      <Referer>http://fwww.xxx.com/?autoplay=1</Referer>
      <lag>0</lag>
      <Connected>921</Connected>
</listener>


Thera are 2 new fields: ID and REFERER.
I've given a look at list clients.xsl , but I'm sorry I'm not able to find how can I modify it to generate a xml without that 2 fields.

Thanks a lot, I appreciate your availability to help us.

Luca
Back to top
View user's profile Send private message
luca066



Joined: 01 Dec 2011
Posts: 41

PostPosted: Sat May 23, 2015 10:17 pm    Post subject: Reply with quote

Thank you Karl for your answer.
I think I've found the solution, now it's about 3 days that I haven't any crash.
The server is a virtual server, it was running with 1 virtual core and 4GB of ram.
Now I've set 2 cores and 8GB of ram and it's working.
In the next days I'll try to understand if it was a cpu or a ram problem.

Anyway, I'd like to use the last version of Icecast as soon as possible.
My problem is the listclients?mount=/xxxx.
After HK7 that command returns a different xml from the previous version:
Code:

<listener id="245">
      <ID>245</ID>
      <IP>1.1.1.1</IP>
      <UserAgent>Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/600.5.17 (KHTML, like Gecko) Version/8.0.5 Safari/600.5.17</UserAgent>
      <Referer>http://fwww.xxx.com/?autoplay=1</Referer>
      <lag>0</lag>
      <Connected>921</Connected>
</listener>


Thera are 2 new fields: ID and REFERER.
I've given a look at list clients.xsl , but I'm sorry I'm not able to find how can I modify it to generate a xml without that 2 fields.

Thanks a lot, I appreciate your availability to help us.

Luca
Back to top
View user's profile Send private message
karlH
Code Warrior
Code Warrior


Joined: 13 Jun 2005
Posts: 5476
Location: UK

PostPosted: Fri May 29, 2015 1:55 am    Post subject: Reply with quote

strange how 2 new fields is causing you problems. If you really want to use the new version without those 2 entries then edit stats.c, search for stats_listener_to_xml function and you will see 2 segments of code containing those eg

snprintf (buf, sizeof (buf), "%" PRIu64, listener->connection.id);
...
xmlNewChild (node, NULL, XMLSTR("ID"), XMLSTR(buf));

and

header = httpp_getvar (listener->parser, "referer");
if (....
{
}


remove or comment them out, rebuild and away you go.....


karl.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
luca066



Joined: 01 Dec 2011
Posts: 41

PostPosted: Wed Jun 17, 2015 9:27 am    Post subject: Reply with quote

Thank you Karl.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Icecast Streaming Media Server Forum Index -> Icecast Server All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group
subRebel style by ktauber