Icecast Streaming Media Server Forum Index Icecast Streaming Media Server
Icecast is a Xiph Foundation Project
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

IceCast -> iPhone

 
Post new topic   Reply to topic    Icecast Streaming Media Server Forum Index -> Icecast Server
View previous topic :: View next topic  
Author Message
Pezmc



Joined: 08 Feb 2010
Posts: 9

PostPosted: Mon Feb 15, 2010 1:34 pm    Post subject: IceCast -> iPhone Reply with quote

Is there anyway to get an IceCast stream to play on an iPhone?

I used to use shoutcast and a simple PLS file got this done, however using an almost identical pls file linking to an IceCast stream the iPhone says: "Safari cannot download this file".

Hope you have a solution!
Back to top
View user's profile Send private message
karlH
Code Warrior
Code Warrior


Joined: 13 Jun 2005
Posts: 5431
Location: UK

PostPosted: Mon Feb 15, 2010 8:48 pm    Post subject: Reply with quote

The message from Safari is too vague to resolve. What do the icecast logs say about this?

karl.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
iunderwood



Joined: 23 Aug 2008
Posts: 113
Location: Leicester, MA

PostPosted: Tue Feb 16, 2010 3:33 pm    Post subject: Reply with quote

You did say "almost identical". What differences exist between the two outside of the differing mountpoint?
_________________
++I;
Back to top
View user's profile Send private message
Pezmc



Joined: 08 Feb 2010
Posts: 9

PostPosted: Thu Feb 18, 2010 1:32 pm    Post subject: Reply with quote

Well one is icecast2, one is shoutcast. I believe they are both streaming Mp3.

It's on the same server.

Is it actually possible to play Icecast inside safari on the iPhone?

My stream is at ***Removed*** the iPhone links to ***Removed***


Last edited by Pezmc on Tue Feb 23, 2010 12:47 am; edited 1 time in total
Back to top
View user's profile Send private message
peepo



Joined: 15 Dec 2007
Posts: 88

PostPosted: Fri Feb 19, 2010 10:16 am    Post subject: Reply with quote

Convert the stream url to an m3u. That should probably work.
Back to top
View user's profile Send private message
LG73



Joined: 29 Dec 2009
Posts: 5
Location: Vancouver, BC, Canada

PostPosted: Sun Feb 21, 2010 9:28 pm    Post subject: Re: IceCast -> iPhone Reply with quote

Pezmc wrote:
Is there anyway to get an IceCast stream to play on an iPhone?

I used to use shoutcast and a simple PLS file got this done, however using an almost identical pls file linking to an IceCast stream the iPhone says: "Safari cannot download this file".

Hope you have a solution!


I have a pls file pointing to an Icecast 128k AAC stream and it works fine in iPhone/Safari/QuickTime. The contents of the .pls file are as follows:

[playlist]
numberofentries=1
File1=http://91.121.91.172:31090/LG73
Title1=LG73 Vancouver's Best Music Mix!
Length1=-1
Version=2

I just specify the URL, port number and mountpoint without any extension on it and it works fine on iPhone, iTunes, WinAmp, FStream, TuneMark, Internet Radio BOX, VLC, and various other players. The PLS file URL is http://www.lg73.ca/LG73_128k.pls and the server is Icecast 2.3.2.
_________________
Regards,
Phil
Back to top
View user's profile Send private message
Pezmc



Joined: 08 Feb 2010
Posts: 9

PostPosted: Sun Feb 21, 2010 11:03 pm    Post subject: Reply with quote

I'm at ***Removed*** (use iPhone/iPod Touch to view iPod version)

My pls looks as follows:
[playlist]
numberofentries=1
File1=http://67.212.189.122:8029/live
Title1=PegFM: AutoDJ

Length1=-1
Version=2

I'm not sure what type of stream it is now, how do I find out?
IceCast page is at: http://67.212.189.122:8029/

I'm using version: Icecast 2.3.2

I still just get Safari cannot download this file, me not sure what I'm doing differently to you?

P.s. many thanks for trying to help


Last edited by Pezmc on Tue Feb 23, 2010 12:48 am; edited 1 time in total
Back to top
View user's profile Send private message
LG73



Joined: 29 Dec 2009
Posts: 5
Location: Vancouver, BC, Canada

PostPosted: Mon Feb 22, 2010 1:25 am    Post subject: Reply with quote

Pezmc wrote:
I'm at http://pegfm.pezcuckow.com (use iPhone/iPod Touch to view iPod version)

My pls looks as follows:
[playlist]
numberofentries=1
File1=http://67.212.189.122:8029/live
Title1=PegFM: AutoDJ

Length1=-1
Version=2

I'm not sure what type of stream it is now, how do I find out?
IceCast page is at: http://67.212.189.122:8029/

I'm using version: Icecast 2.3.2

I still just get Safari cannot download this file, me not sure what I'm doing differently to you?

P.s. many thanks for trying to help


Looks like you had some illegal characters in that pls file. I edited those out and cleaned up the line breaks and now it works on my iPhone. You can test that at this URL: http://www.lg73.ca/live.pls. Feel free to use that pls file for your site. I'll delete it once I know you have it.
_________________
Regards,
Phil
Back to top
View user's profile Send private message
Pezmc



Joined: 08 Feb 2010
Posts: 9

PostPosted: Mon Feb 22, 2010 3:06 am    Post subject: Reply with quote

Thank you very much for your time!

However I am left somewhat confused, I downloaded that file from your server & put it straight onto mine at ***Removed***/iphone.pls and it still shows that error, I even cleared the cache!

The one on your website works fine. Downloaded the file in both chrome and IE and uploaded using both Dreamweaver and Filezilla FTP, what is going on?


Last edited by Pezmc on Tue Feb 23, 2010 12:48 am; edited 1 time in total
Back to top
View user's profile Send private message
LG73



Joined: 29 Dec 2009
Posts: 5
Location: Vancouver, BC, Canada

PostPosted: Mon Feb 22, 2010 7:59 am    Post subject: Reply with quote

Pezmc wrote:
Thank you very much for your time!

However I am left somewhat confused, I downloaded that file from your server & put it straight onto mine at http://pegfm.pezcuckow.com/iphone.pls and it still shows that error, I even cleared the cache!

The one on your website works fine. Downloaded the file in both chrome and IE and uploaded using both Dreamweaver and Filezilla FTP, what is going on?


That is very strange. I tried the link to the copy on your server on my iPhone off this page and it fails. The link to the copy on my server works. There must be something odd with how your web server is dishing out .pls files.

On my Mac with Safari and iTunes the .pls file from your server does work. This could be a case of a text encoding issue that adversely affects the iPhone but not Mac or Windows.
_________________
Regards,
Phil
Back to top
View user's profile Send private message
Pezmc



Joined: 08 Feb 2010
Posts: 9

PostPosted: Mon Feb 22, 2010 9:04 am    Post subject: Reply with quote

LG73 wrote:
Pezmc wrote:
Thank you very much for your time!

However I am left somewhat confused, I downloaded that file from your server & put it straight onto mine at ***Removed***/iphone.pls and it still shows that error, I even cleared the cache!

The one on your website works fine. Downloaded the file in both chrome and IE and uploaded using both Dreamweaver and Filezilla FTP, what is going on?


That is very strange. I tried the link to the copy on your server on my iPhone off this page and it fails. The link to the copy on my server works. There must be something odd with how your web server is dishing out .pls files.

On my Mac with Safari and iTunes the .pls file from your server does work. This could be a case of a text encoding issue that adversely affects the iPhone but not Mac or Windows.


Same for me, it works in VLC, iTunes, Windows Media Player, but not on the iPhone. I see no reason why my web server would be doing anything differently (Vanilla Apache).

Both files are identical and I even chmodded everything to 777 just in case.

I can't find any information on why this would be online...
I have posted in the Apple forums here: http://discussions.apple.com/thread.jspa?threadID=2345384&stqc=true

Any ideas?


Last edited by Pezmc on Tue Feb 23, 2010 12:48 am; edited 1 time in total
Back to top
View user's profile Send private message
Pezmc



Joined: 08 Feb 2010
Posts: 9

PostPosted: Mon Feb 22, 2010 8:09 pm    Post subject: Reply with quote

Resolved!

Anyone else with the same problem it is probably because your web server does not know what a PLS is and so the MIME isn't correct.

In apache, creating a .htaccess with the following in fixes the problem!
Code:
AddType audio/x-scpls pls


Thanks for everyone trying to help, especially LG73!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Icecast Streaming Media Server Forum Index -> Icecast Server All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group
subRebel style by ktauber